Gedownload older version of Apple Arcade game (Lego Brawls)

Created at: 2021-05-20 11:46:54
Questioner General

I was forced to do a fresh install of macOS Catalina on my Mac mini 2012.

Before I was forced to do so. There was a perfectly working version of Lego Brawls on the machine. I did not backup the game because it's freely downloadable under our Apple Arcade subscription.



After reinstallation the App Store/Arcade refuses to download the game that IS in fact supported(!) saying Big Sur is needed.



  1. Where to download the 'old' version I guess 2.1 or so that still supports Catalina
  2. Why can't Apple built in 'download the last working version for your OS'
  3. Can someone send me the old version (link) of their Catalina version



Remember Arcade is PAID content!

Answer #1:

By: Prof. Augustus Oberbrunner Jr.

I was forced to do a fresh install of macOS Catalina on my Mac mini 2012.

Before I was forced to do so. There was a perfectly working version of Lego Brawls on the machine. I did not backup the game because it's freely downloadable under our Apple Arcade subscription.



After reinstallation the App Store/Arcade refuses to download the game that IS in fact supported(!) saying Big Sur is needed.



  1. Where to download the 'old' version I guess 2.1 or so that still supports Catalina
  2. Why can't Apple built in 'download the last working version for your OS'
  3. Can someone send me the old version (link) of their Catalina version



Remember Arcade is PAID content!

Answer #2:

By: Cody Labadie

You can try giving feedback to the developers through their support link in the App Store - https://www.lego.com/en-gb/service/ - but I don't hold out much hope. If they've decided to drop support for Catalina then I cannot see that changing. Like you when I check from Catalina I see a banner stating that macOS 11.0.0 or later is required. For regular apps it can sometimes be the case that if you get or buy the app on a newer system you may be able to install a compatible copy on an older device, but this feature likely hasn't been implemented for Apple Arcade or this app since you will have obtained it previously so it should be in your account already.



tt2

Answer #3:

By: Nedra Weimann

You can try giving feedback to the developers through their support link in the App Store - https://www.lego.com/en-gb/service/ - but I don't hold out much hope. If they've decided to drop support for Catalina then I cannot see that changing. Like you when I check from Catalina I see a banner stating that macOS 11.0.0 or later is required. For regular apps it can sometimes be the case that if you get or buy the app on a newer system you may be able to install a compatible copy on an older device, but this feature likely hasn't been implemented for Apple Arcade or this app since you will have obtained it previously so it should be in your account already.



tt2