Update my Mac OS, I've heard that Logic Pro 10.6.1 won't work, is that true?

Created at: 2021-04-26 00:08:13
Questioner General

I'm afraid to update my Mac Air, I've heard that Logic Pro 10.6.1 won't work, is that true? I'm currently running Catalina 10.15.7

Answer #1:

By: Ms. Shanel Hyatt

I'm afraid to update my Mac Air, I've heard that Logic Pro 10.6.1 won't work, is that true? I'm currently running Catalina 10.15.7

Answer #2:

By: Orlando Strosin

Not true. Logic Pro 10.6.1 works with Catalina 10.15.7 and higher.

Answer #3:

By: Sophia Rau

Not true. Logic Pro 10.6.1 works with Catalina 10.15.7 and higher.

Answer #4:

By: Ines Parisian

Thanks I'll give it a try when I have a few hours.

Answer #5:

By: Daija O'Conner Sr.

I recently updated to Big Sur and Logic Pro 10.6.1 works, BUT several AU plugins (very expensive ones!) don’t work at all. I’m now faced with reverting back to Mojave.

Answer #6:

By: Abigale Labadie

I'm running 10.6.1 on the latest Big Sur update with no problems at all. Macbook pro 2019